[LINK]: PLCSim advanced 1.0 for S7-1500 v2.0 only (not 2.1)

SIMATIC S7-200/300/400, Step7, PCS7, CFC, SFC, PDM, PLCSIM,
SCL, Graph, SPS-VISU S5/S7, IBHsoftec, LOGO ...
Post Reply
Info
Faq & Info
Faq & Info
Posts: 401
Joined: Wed Oct 05, 2005 9:00 am

[LINK]: PLCSim advanced 1.0 for S7-1500 v2.0 only (not 2.1)

Post by Info » Wed Oct 12, 2016 7:40 pm

PLCSim Advanced (TIA Portal V14)
The version of S7-PLCSIM Advanced supports the following SIMATIC CPU series:
● S7-1500, S7-1500F, S7-1500C, S7-1500T and S7-1500TF v2.0 only (not work with v2.1)
● ET 200SP and ET 200SP F

S7-PLCSIM Advanced V1.0 does not support the simulation of the following CPUs:
● S7-1200 CPUs [dead]
● ET 200pro, ET 200pro F CPUs [dead]
● ET 200SP Open Controller CPU 1515SP PC [dead]
● Software Controller [dead]

Communication
S7-PLCSIM Advanced supports communication via Softbus or TCP/IP.
S7 PLCSIM Advanced enables C++ and C# programs and simulation software to access
SIMATIC CPU series supported by S7-PLCSIM Advanced via the user interface (API).
S7-PLCSIM Advanced and S7-PLCSIM V14 (for S7-1200 and old S7-1500 v1.8) cannot be installed on the same PC or the same virtual machine.
The communication between the two applications cannot be simulated.
S7-PLCSIM V5.4 SP8 is automatically installed with S7-PLCSIM Advanced.
The communication between the two applications can be simulated.

===============================
S7-PLCSIM V14
The version of S7-PLCSIM supports the following SIMATIC CPU series:
● S7-1200 and S7-1200F (thnx)
● S7-1500, S7-1500F, S7-1500C, S7-1500T and S7-1500TF
● ET 200SP and ET 200SP F
Communication
S7-PLCSIM V14 supports communication via Softbus.

S7-PLCSIM V14 and S7-PLCSIM Advanced cannot be installed on the same PC or the same virtual machine.

Прояснилась ситуация с этим расширенным отладчиком - работает только со старыми версиями S7-1500 v2.0...
то есть в проекте надо заменять процессор на версию 2.0
The firmware within PLCSIM Advanced correlates with the firmware 2.0 of a PLC S7-15xx with firmware 2.0.

The download of a PLC with newer firmware versions > firmware 2.0 will end in an abortion of the download.
https://www.youtube.com/watch?v=Ird0ArHtMC8

Beavis
Posts: 14
Joined: Tue Dec 16, 2008 1:28 pm
Location: Asia

Re: [Request]: PLCSim advanced 1.0

Post by Beavis » Mon Oct 24, 2016 2:28 pm

Theoretically to test an OPC connection you might want to consider the classic PLCSIM v13 or V14 with NetToPlcSim
https://sourceforge.net/projects/nettoplcsim/
Last version should work with TIA too

Tia v14 introduced a new advanced simulator that is able to simulate also tcp open communications:
https://support.industry.siemens.com/cs/ww/en/ps/24442

anyone has a copy of it?
thanks

Hammer2
Posts: 4
Joined: Wed Feb 29, 2012 7:41 am

Re: [Request]: PLCSim advanced 1.0

Post by Hammer2 » Fri Mar 31, 2017 12:41 pm

According to TIA V14 SP1 delivery notesa the trial version (21 days) will be available for SIMATIC PLCSIM Advanced V1.0 SP1 in April 2017.

https://support.industry.siemens.com/cs ... 0&lc=en-WW

Rex2701
Posts: 262
Joined: Wed Oct 13, 2010 8:44 am
Location: Russian Federation

Re: [Request]: PLCSim advanced 1.0

Post by Rex2701 » Thu Apr 13, 2017 8:11 am

SIMATIC S7-PLCSIM Advanced V1.0 SP1 Trial Download is available.
https://support.industry.siemens.com/cs ... l-download

Info
Faq & Info
Faq & Info
Posts: 401
Joined: Wed Oct 05, 2005 9:00 am

Re: [Request]: PLCSim advanced 1.0

Post by Info » Thu Apr 13, 2017 9:09 am

kill PLCSIM v14?
Image
Image
Ok
PLCSIM v14 killed... but no PLCSIM for test Portal (h)
Image
в общем непонятная фигня... по просьбе расширенного 1.0 убил PLCSIM v14
и теперь невозможно отлаживать, то что без проблем отлаживалось
шаг вперёд, два шага назад... (boom)
нам не нужен такой расширенный неотлаживающий отладчик

Прояснилась ситуация с этим расширенным отладчиком - работает только со старыми версиями S7-1500 v2.0... то есть в проекте надо заменять процессор на версию 2.0
The firmware within PLCSIM Advanced correlates with the firmware 2.0 of a PLC S7-15xx with firmware 2.0.

https://www.youtube.com/watch?v=Ird0ArHtMC8

A PLC with earlier firmwar versions e.g. firmware 1.8 can be downloaded to PLCSIM Advanced.
The download of a PLC with newer firmware versions firmware 2.1... will end in an abortion of the download.
install and see "New keys" folder
после установки смотри папку "Новые ключи"
Image
or wait/или жди
Image

Chief-ir
Posts: 2
Joined: Sat Oct 07, 2017 3:18 pm

Re: [LINK]: PLCSim advanced 1.0 for S7-1500 v2.0 only (not 2

Post by Chief-ir » Sat Oct 07, 2017 3:26 pm

Господа, подскажите пожалйста, у кого получилось установить на Windows 10?
Самим Сименсом поддержка данной ОС для PLCSIM Advanced V1.0 SP1 заявлена, однако при установке вылетает сообщение о необходимости доустановить WinPcap, естественно я его пытаюсь ставить, но он говорит что на ПК уже установлена более новая версия и устанавливаться отказывается.
Кто-нибудь сталкивался с такой проблеммой?

CoMod
Site Admin
Posts: 3508
Joined: Thu Feb 16, 2006 3:25 pm
Location: Russia
Contact:

Re: [LINK]: PLCSim advanced 1.0 for S7-1500 v2.0 only (not 2

Post by CoMod » Sat Oct 07, 2017 4:07 pm

попробуй поправить \InstData\Resources\SIA2.ini
; добавь в начале непонравившейся строки
Image

Chief-ir
Posts: 2
Joined: Sat Oct 07, 2017 3:18 pm

Re: [LINK]: PLCSim advanced 1.0 for S7-1500 v2.0 only (not 2

Post by Chief-ir » Sat Oct 07, 2017 6:22 pm

CoMod wrote:попробуй поправить \InstData\Resources\SIA2.ini
; добавь в начале непонравившейся строки
Image
Спасибо, но не помогло. На удивление, среди установленных программ, оказался некий WinPcap for Windows 10, видимо автоматически установился с "обычным" PLCSIM или Тиа Порталом. После его удаления, WinPcap из папки Support установился без проблем и появилась возможность продолжать установку основной программы.

Post Reply